I followed the steps here to add an EXT4 partition on my 8gb sd card: http://www.addictivetips.com/mobile/properly-partition-sd-card-for-app2sd-android-roms/

Now I have 6.xGB FAT32 as the primary partition, and a 1GB EXT4 logical partition. But my Samsung Galaxy Ace (running on CyanogenMod-7.2.0-C1-cooper, official nightly build) doesn't recognize the sd card anymore.

Please help. Thanks.

Update: I gave up and reformatted it back to a single FAT32 partition, copied my backup into the sd card, now the apps don't get recognized. Please, please help me. :(

  • I just tried re-partitioning it in Windows using Partition Wizard, it didn't work. – d4ryl3 Apr 5 '12 at 5:18
  • Small note. The original instructions call for partitioning the card using a reader. If you are doing this on a laptop, it is essential to use an external USB card reader. Most built-in ones found on most laptops do not properly write partition tables (even if software packages like GParted or Partition Wizard report success.) That will make the newly created partition(s) unreadable in the phone. – Chahk Apr 5 '12 at 13:07
  • Good to know. Although I used a card reader for the process. It's attached to a usb hub, I don't know if that may have caused anything. – d4ryl3 Apr 6 '12 at 0:15

If your phone is rooted and got ClockworkMod installed, then try formatting and creating an EXT partition in ClockworkMod. Its the most simplest and easiest way to do it. It will automatically take care of your Fat partition too.

For more info, read this article

  • I will try that next. Say, do you have any idea why my apps weren't being recognized? – d4ryl3 Apr 5 '12 at 8:11
  • did you copy .android_secure folder to your sd card too? – waqaslam Apr 5 '12 at 8:35
  • Huh, I think when I did a ctrl+a on my ubuntu installation, hidden files were not shown, thus, .android_secure wasn't copied. I get it now, thanks. Also, that method with CWM worked. Thank you so much. – d4ryl3 Apr 5 '12 at 9:05
  • When you format your SD card to have multiple partitions, you need to change the Android system files to reflect this. CWM does the modifications for you automagically :) – Logos Apr 5 '12 at 10:44
  • I see, that might be the reason I had trouble in the first place. Thanks. – d4ryl3 Apr 6 '12 at 0:14

Minitool Partition Magic did not work for me. Instead, I formatted and partitioned the card directly through adb in CWM recovery using this guide on xda-developers forums. Am using Link2SD (similar to App2SD) fine now on CM 11 KitKat 4.4.2


I had the same problem. Use minitool partition magic and set your card partition to primary partition. Apply changes and that's it.

  • 1
    Is minitool partition magic an Android app? Can you provide a link to it? – geffchang Apr 11 '14 at 9:10

I had the same problem and I found a solution for another SD card
Partion the SD card using minitool to one FAT32 + one EXT2 Make them primary and non-active

Works on Samsung Ace duos GT S6821, Huawei Y625-U32 and some Sony device

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.