0

When connecting my Samsung Galaxy S7 to bluetooth-devices (cars, bluetooth-loudspeakers etc.) the music is normally played but the devices' control units do not work. It is not possible to control the the playback (skip a track, pause...). Also meta-data about the track (titel, artist, ...) ist not displayed in the car's system.

The Galaxy S7 runs Lineage OS 14.1 with Android 7.1.2. I also tried using different other mobiles with those bluetooth devices and basically all of them worked perfectly fine including an older Samsung Galaxy S5 with CyanogenMod 13 and Android 6.x.x. Considering that I am pretty sure that the problem is at the Galaxy S7.

When I first got the phone the control units were still working for it but at some point it simply stopped, I don't know why. Already before the issue I had Lineage OS installed but at that time they still had released frequent updates so one of those might also be responsible. I also thought that some self installed (root requiring) app could be the problem.

In my phone I denied lots of permissions to many apps (also system apps). Could the problem be there? I already tried allowing them to some apps (e.g. Google Play Services) but without success. I am also using the additional permission manager App Ops and the Shizuku Manager. I tried disabling both but still it didn't work.

Can anyone help me, please? I really don't know what to do. If the only solution should be installing a new ROM, which one could solve the problem?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.