0

I am attempting the unlock the bootloader on my Google Pixel 2 XL. I know this problem seems to be very common, but I have yet been unable to find a solution for my particular case after searching through just about all the relevant cases online. I have installed the latest Google USB drivers as well as the ADB/Fastboot platform tools. When I run adb devices I get one listed, which is my phone. I am able to then run adb reboot bootloader to get to the fastboot screen. This is where my problem starts.

Not only does the device not appear under fastboot (when I run fastboot devices), but I don't think my PC is recognizing that an Android phone is connected. Many guides at this point say to go to Device Manager, and find the Android device under 'Other Devices' with a yellow indicator showing that it isn't working, and then point Windows towards a working driver. However, my Device Manager looks like this:

Device Manager

As far as I can tell, when I plug in the phone when in fastboot mode, it appears as Intel(R) USB 3.1 extensible Host Controller - 1.10 (Microsoft) and as USB Root Hub (USB 3.0)

I guess my question is at this point is this a hardware issue? I can do everything with my Pixel normally, like exchange files and USB debugging.

  • adb (USB-debugging) is not related to fastboot, so they need separate drivers androidadbdriver.com/google-pixel-2-usb-drivers – alecxs Jun 25 at 15:44
  • Yes, I believe I have both installed. I did go through the instructions for manually installing the Google USB drivers that you linked, but am in the same situation. – Dario Macieira Jun 25 at 16:03
  • is fastboot working with other devices? did you try manually assign the fastboot drivers for Intel(R) USB 3.1 extensible Host Controller? – alecxs Jun 25 at 16:51
  • This is my only android device, so I'm not sure. I did manually assign the drivers as well, but to the same result. I ended up borrowing another PC laptop to unlock the bootloader. My PC is a type known for its issues recognizing connected devices (graphics card, headphones, keyboard lights etc.) so this isn't actually a surprise. – Dario Macieira Jul 2 at 15:23
  • run cmd.exe (as Administrator) instead of Powershell – alecxs Jul 2 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.