5

Right now I own a Sony Ericsson Xperia x10 mini and I rooted it. I had this program installed from Android Marketplace that allows you to delete applications.

So guess what... I deleted several applications for testing purposes and I knew that if I uninstall Android System it would break everything.

I did that epic "mistake" for testing purposes (don't try this).

The thing is how do I fix this? I have spent some time reading through forums and installed Flashtool and downloaded the ftf file (X10a_v2.1.update-1_2.1.A.0.435_Generic.ftf) in C:\Flashtool\firmwares directory.

What I have to deal with right now: - My mobile phone switched off when deleted Android System so I decided to boot it to see if any error messages comes up. - Now my phone won't power off due to the lack of Android System. So I have to use a torx screwdriver to remove the screws and take off the battery (because Flashtool requires the phone to be switched off) but unfortunately the Torx I have is one size bigger than the required one for Xperia's screws. - I guess I have to wait until the battery is dead or I should just get a proper Torx screwdriver.

The thing is that I have another Xperia x10 mini as well (works for now - didn't try any uninstall) and connected it to FlashTool and followed the instructions to flash it but I keep getting this error message:

ERROR - ERR_SEVERITY="MAJOR";ERR_CLASS="SECURITY_CLASS";ER R_DYNAMIC="SIN header verification failed"

I tried to figure out what's causing this and I end up with the "locked bootloader solution". I tried the instructions read here: http://unlockbootloader.sonymobile.com/instructions but when I typed ##7378423## no service menu was available...

That happened to the working Xperia phone. How would I possible do that on a broken Xperia?

Any suggestions would be highly appreciated!

We're all learning through our mistakes after all.

5
  • Do you have custom recovery installed or made a nandroid backup by any chance?
    – roxan
    Commented Apr 5, 2012 at 8:15
  • Unfortunately no. I guess I have to completely re-install Android system on the phone but I don't know how to do this since the above didn't work.
    – ggirtsou
    Commented Apr 5, 2012 at 8:22
  • Is the phone running Android 2.0 or 2.1? If it's higher than that, the referenced bootloader hack will not work.
    – Logos
    Commented Apr 5, 2012 at 10:48
  • It had 2.1 installed.
    – ggirtsou
    Commented Apr 6, 2012 at 8:00
  • Try flashify to flash your custom recovery.
    – Vivek Ji
    Commented Jun 5, 2016 at 3:11

1 Answer 1

2

If you didn't already have your bootloader unlocked and tools in place to reload the Android operating system (ie, ROMs or disk images), I strongly suspected you are completely screwed.

2
  • Why's that? I mean how do companies install OS on mobiles? Can't I do that?
    – ggirtsou
    Commented Apr 6, 2012 at 11:42
  • 2
    You can install an OS from scratch on your phone, but you need a specialized environment and tools to do so and those are often proprietary and/or secret. It is far easier to load a disk image (ROM) than do a base install. Either way, part of the process is an unlocked bootloader so that you can boot into an environment/tool instead of the existing OS. If you don't have a way to boot into something besides the installed system and have pooched that system - generally the only way you as a consumer have available to hack the bootloader - then you're up the creek.
    – Logos
    Commented Apr 6, 2012 at 12:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .