5

I have a very similar problem to e.g. here.

I installed Android-x86 on a partition on my Acer Aspire Switch 10E next to Windows.

I added Grub as trusted boot option in the UEFI and let Secure Boot enabled.

Using this I can completely boot and reboot into e.g. Android x86 version 8.1-R2

But the problem is: in this version my Realtek RTL8723BS is not supported -> No WiFi/Bluetooth!


So I worked my way back to older versions (I need at least Android 6.0). Using CM 14.1-R2 and Androidx86 7.1-R2 I have a strange behavior:

Right after the installation if I select "Run Android" everything works fine, it boots normal, WiFi/Bluetooth everything fine!

But I am not able in any way getting it to run again after a reboot. It is forever stuck on a black screen with only displaying a fix (not blinking)

_

I already searched for two days and tried a lot of parameters and settings in the Grub entry like nomodeset, xforcevesa etc ... nothing worked so far.

I also tried both 32bit and 64bit versions (the device is 64bit) but it made no difference.

I don't understand what I am doing wrong or why it boots all fine the first time if not going for the reboot but directly to the Run Android option. So I guess it can not be due to unsupported hardware since the system basically works ... I just can not boot into it anymore after shutting down / reboot.


Does anyone have a solution for that?


Note: I am not speaking about a Virtual Machine here!

0

3 Answers 3

4

I found disabling 3D acceleration and setting the graphic controller to VBoxVGA solves the issue.

1
  • As I mentioned back then .. it wasn't a virtual machine! It is Android flashed to an actual tablet hardware device ;)
    – derHugo
    Commented Jun 12, 2023 at 6:39
1
  1. When you see the selection, press E on the keyboard (for editing). [ You will see a line after it ]

  2. Replace quiet with nomodeset xforcevesa. [ Then press B for boot ]

  3. Your Android will boot correctly only one time. [ Android will start running ]

  4. Now press Alt + F1 to launch console.

  5. Type: mkdir /mnt/sda

  6. Type: mount /dev/block/sda1 /mnt/sda

  7. Type: vi /mnt/sda/grub/menu.lst [ You can search use of vi on Google ]

  8. Replace quiet with nomodeset xforcevesa.

  9. Press Esc, and :wq

  10. Type reboot. [ Your Android will work fine ]

0

When you change the internal frame where the UEFI firmware settings to the EFI framework setting, change the boot order.

You have to make a small partition for grub, go back, and change it back. Otherwise, it won't boot the second time.

1
  • 2
    Sorry I fear I didn't fully understand what you mean. Could you explain step by step what I have to do?
    – derHugo
    Commented Jun 26, 2019 at 15:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .