0

On my custom rom, the IP address doesn't get assigned automatically because the wifi chip uses wlan but the rom uses wlan0, i need help to find a way to find the IP address and manually type it or find an app for wifi tethering or find a way to make the IP static. Any suggestions?

  • ip address add 192.168.43.1 dev wlan. Requires root. Or you can also try to create a Wi-Fi interface named wlan0: iw dev wlan interface add wlan0 type managed. But how the rest of the network routing works if ROM is unaware of Wi-Fi interface name? – Irfan Latif Jun 28 at 18:25
  • Its a problem because the rom is a port from a newer device that uses wlan0. Wifi didn't work at first and it took a week to get fixed. – thekillerbunny Jun 29 at 3:55
  • Also i tried the first command and it seems that it has worked but the second i turn on hotspot it changes – thekillerbunny Jun 29 at 4:08
  • In 2nd case you'll to do more manual work. In both cases you can replace /system/bin/dnsmasq with a shell script to automate the steps when hotspot is turned on. See my recent answer: android.stackexchange.com/a/214072/218526. Or you can use init's *.rc file for same purpose. See this answer:android.stackexchange.com/a/213626/218526 – Irfan Latif Jun 29 at 4:57
  • I tried both still no luck it gives me errors. But for the command ip address add 192.168.43.1 dev wlan0 it adds the ip. maybe i can find a way to add the ssid and passphrase and that's it – thekillerbunny Jun 29 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.