0

I subscribed to Google Fi for transferring my American phone number to this service.

I have Google Pixel 3a XL, which has esim.

To activate Google Fi service I need to install Google Fi App.

This service is available only in USA.

I have American address and American phone, but right now I'm in Canada.

So when I try ti install it, I get error:

This item isn't available in your country enter image description here

Okay, I installed TunnelBear VPN, but is having the same error.

Should I try different VPN or change some setting on my phone?

UPDATE: Following this article, I installed VPN Unlimited on my other phone (Windows phone) and connected my Pixel to this phone by hotspot.

I cleared cash on both phones and set location off.

Now browser show me weather for Los Angeles. But Google Play still gives me the same error.

Btw, I have US Profile in Google Play.

Still should to try Fake GPS, but may I should drive to USA to activate Fi.

3
  • While you are using VPN your location may not have been updated. I would go into Airplane mode and use a Fake GPS provider to place yourself near where your VPN endpoint is located. Then try downloading Google Fi. Google itself may be using your old location to prevent location spoofing (1000km change in 10 mins doesn't seem real), so a few hours of device off in Airplane mode might help before connecting a renamed router (Google records wifi locations). Note that activation of Google Fi itself may require access to a supported US carrier. – Morrison Chang Jun 29 '19 at 4:11
  • okay, will try. Found interesting article: medium.com/@panteliszirinis/…, he used two phones, one with VPN and hotspot to connect other phone. – Alexan Jun 29 '19 at 5:00
  • okay, installed from there: apkpure.com/google-fi/com.google.android.apps.tycho/… – Alexan Jun 30 '19 at 14:24
1

Change your country setting in Google PlayStore Account settings. You'll get a notification that you can only do this once a year blah blah blah, but right after I changed mine from New Zealand to USA I was able to download and activate the app.

Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.