1

I have a Asus Zenfone 2 and a few days ago it ran out of battery and turned off. Then after I charged it up and restarted it, it wouldn't turn on. It gets to the logo and the loading circle and just gets stuck there forever.

I can get into recovery, but can't do anything in recovery, because everything gives this error:

E:failed to mount /cache (invalid argument)

Trying to wipe cache, factory reset the phone, mount /system, flash a ROM from SD card, ADB sideload, everything gives the error multiple times. Factory reset formats /data fine, but when it gets to /cache, gives the error and aborts.

Same thing with fastboot. I tried to flash TWRP (I have stock recovery) and I tried to erase and format cache through fastboot, but both give this error:

FAILED (remote: 'Can not mount the necessary partition')

fastboot: error: Command failed

Is there anything I can do to format the phone or somehow rebuild the partitions without being able to flash anything via recovery or fastboot?

I don't know if tools like AFT or xfstk can do anything for me.

Edit: I don't think the EMMC chip is dead, because the recovery partition is still fine, I can still boot into recovery and when I did a factory reset, it formatted /data without any errors, only had an error when it started formatting /cache.

When I was looking for a solution to this problem, I read somewhere that sometimes when the device gets interrupted, like when it shuts down suddenly, to prevent data loss android would change permissions on the /cache partition to read only or something like that. This would certainly explain what happened to my phone. Just need to think of a way to access ADB shell on it to try to change permissions. Shell doesn't work in ADB sideload mode, that's the only ADB thing the stock recovery has. Is that a similar thing in fastboot by any chance?

  • fastboot format:ext4 cache (or without :ext4) will do the trick – alecxs Jun 30 at 7:20
  • That still gives the error remote: 'Can not mount the necessary partition' – Curiosity Jun 30 at 10:22
  • Try this three together fastboot oem start_partitioning fastboot oem wipe cache fastboot oem stop_partitioning – alecxs Jun 30 at 12:05
  • fastboot oem wipe cache gave this error: FAILED (remote: 'unknown OEM command'). Now I tried to do fastboot format cache again, this time it went through most of it successfully, then it got to the end and I still got this error: Writing 'cache' FAILED (remote: 'Can not mount the necessary partition'). – Curiosity Jun 30 at 14:06
  • 1
    The possibility of dying eMMC can't be negated if you have used your device for a few years. Some cheap eMMCs have very limited E/P cycles before they wear out. Not necessarily all partitions dye at once, usually those with filesystems and mostly /data and /cache are affected because they are excessively written to. Better is to try factory firmware flashers if you can manage to provide. See this for some technical stuff. – Irfan Latif Jun 30 at 21:25
0

download TWRP for your device, then fastboot boot C:\adb\twrp-3.3.1-0-Z00*.img from twrp: adb shell from shell: mke2fs -t ext4 /dev/block/bootdevice/by-name/cache

  • Damn, looks like the phone is overwriting it. It executes the command and reboots, but boots up into stock recovery. Weird, bootloader should be unlocked. – Curiosity Jun 30 at 19:07
  • overwriting TWRP with stock recovery usually happens when /system/recovery-from-boot.p is executed (on each boot). but with the above command it will boot directly into TWRP without flashing recovery – alecxs Jun 30 at 20:18
  • It should, but it just boots into stock even though the console says it was successful. – Curiosity Jun 30 at 21:06
  • probably downloaded wrong image? there are 4 different versions Z00A Z008 Z00T or Z00L. or try some older version – alecxs Jun 30 at 22:37
  • Definitely Z00A. Just tried 3.1.1.0, but same, just reboots to the broken android logo, then the button combo opens stock recovery. Powershell says Sending 'boot.img' (13915 KB) OKAY [ 0.579s] Booting OKAY [ 0.340s] Finished. Total time: 1.008s – Curiosity Jul 1 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.