0

I have few devices in my local network. I want them to have names like in this example:

192.168.1.1    router.home
192.168.1.2    nas.home
192.168.1.3    rpi.home

I setup dnsmasq server on my NAS server (192.168.1.2) and edited router's DHCP config to have IP of NAS as first DNS resolver.

When I enter nas.home/ on my desktop PC everything works fine, but Android phone on same network does not, even I see right settings in WiFi description (first DNS resolver is 192.168.1.2, static IP etc.)

What can be problem? Even my notebook on WiFi works fine. Just phones not work.

migrated from superuser.com Jul 3 at 13:00

This question came from our site for computer enthusiasts and power users.

  • Because Android loves Google, it must be sending DNS queries to 8.8.8.8. Which Android version you are on? If it's Pie, disable Private DNS in settings. If you have root, force DNS queries to your server by: iptables -I OUTPUT -p udp --dport 53 -j DNAT --to 192.168.1.2:53. Also clear DNS cache: ndc resolver clearnetdns wlan0. – Irfan Latif Jul 3 at 13:12
  • @IrfanLatif Private DNS is turned off, cleanup not helped. Sure I can force it to use my dns but I dont want to do this on every Android Phone I have at home. – Baterka Jul 4 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.