0

I'm trying to install LineageOS and then GAPPS on my Pixel XL from TWRP recovery. I'll try to Advance Wipe the /systems directory and Format Data, but I continue to get multiple errors:

Failed to mount '/system' (Device or resource busy)

Failed to mount '/vendor' (Device or resource busy)

And

Unable to wipe 'System'

Unable to wipe '/system'

 to

If I just continue with adb sideload lineageos.zip most of the time it stops about halfway (PowerShell shows 47%) through and then TWRP shell shows:

Installing zip file '/sideload/package.zip'
Step 1/2
Step 2/2

I then try to sideload the gapps.zip file and get another error saying /system doesn't have enough space. I've tried sideloading several different gapps versions including their smallest pico zip fie of 91.39 MiB.

I am able to then boot into LineageOS, but no GAPPS show and I'm not able to run any new apps installed via APK without them crashing.

My assumption is that I need to fully wipe system and format it, but I've been trying for two days now and still get the above (Device or resource busy) errors. Any help would be much appreciated!

  • Why are you formatting /system and /vendor with FAT? That won't work, Android requires a filesystem aware of UNIX permissions. Try with ext4 or f2fs. – Irfan Latif Jul 5 at 3:24
  • @Lrfan Latif how do I do that? TWTP only gives me the format options, but doesn't let me choose what type of filesystem (I least that I'm aware of ). – orangeMint Jul 5 at 6:10
  • TWRP does have Repair or Change Filesystem option in Advanced Wipe. You can also do that directly from terminal: mkfs.ext4 /dev/block/bootdevice/by-name/system. For A/B devices system would be either system_a or system_b. If there is no mkfs.ext4, look for something like make_ext4 in /sbin. I don't remember exact name of binary, Android uses different than Linux. – Irfan Latif Jul 5 at 6:25
  • besides the fact that TWRP think it's fat, that does not explain why it fails. busy means there are open files or folders, you must umount -l the device first. mke2fs -t ext4 is the busybox applet for formatting – alecxs Jul 5 at 15:17
  • @alecxs what process can be using /system or /vendor in TWRP? The busy message could be because of repeated attempts, where the previous threads of mkfs or fsck could be keeping block devices busy. – Irfan Latif Jul 5 at 15:55
2

I fixed this by using an older version of TWRP (3.2.3.1), then I downloaded GAPPs from a different source and installed using adb sideload now all is working.

  • 1
    Thanks! I had this same issue with TWRP v3.3.1-0. v3.2.3.1 worked! – Stephen Niedzielski Sep 9 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.