3

I found the option to enable DNS over HTTPS for Firefox on the desktop but I can't find it on the Android version of the browser. Is it supported? How do I enable it?

migrated from superuser.com Jul 10 at 9:20

This question came from our site for computer enthusiasts and power users.

  • Which Android version you are on? If Pie, turn on Private DNS from Settings. It's DoT for whole device. Or may use something like this or this. – Irfan Latif Jul 10 at 11:47
2

Although I have not been able to prove it's really changing the routing of DNS queries, I have changed the settings on Firefox for Android: network.trr.mode to 2 (fail-over enabled) or 3 (fail-over not enabled) and network.trr.uri to 1.1.1.1 (Cloudflare) or 8.8.8.8 (Google) or 9.9.9.9 (Quad9). This came from this Mozilla page (not specific to Android Firefox). So you type about:config in the address bar, then search for and change the network.trr* settings.

But as mentioned by Irfan, you can have all your DNS go to cloudflare by using their 1.1.1.1 app, or if you're on the Android Pie, you can go to Settings > Network & Internet > Private DNS and select Automatic (I'm sure that's GOT to be Google's 9.9.9.9) or Private DNS provider hostname with 1dot1dot1dot1.cloudflare-dns.com, for instance (credit to this page on TechRepublic).

  • 1
    You'd have to set the network.trr.mode to 3 to test if it's really working. Mode 2 uses regular DNS as a backup if DOH fails, so you won't really know if you're using DOH if you don't test it in mode 3 first. – John Aug 19 at 16:53
  • For some reason using network.trr.mode to 3 fails to work when I'm on mobile data, but works fine when I'm on WiFi. – m-p-3 Oct 14 at 1:21
1

I try to complete Dale answer

  • Open Firefox and type: about:config

  • filter with: network.trr.* and set the following values:

    network.trr.mode value 3

    network.trr.bootstrapAddress and set value as one ip from this page (mine value is currently 104.16.249.249)

  • now open a new tab to this page used to verify if everything is working. You should have all green except sni. To make all green you should

  • switch tab and go back to config page

  • change filter with: network.security.* and set:

    network.security.esni.enabled value true

  • go back to previous tab and refresh. You should have all green.

credits/references:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.