0

My OS is majaro linux.
My phone is fly nimbus 8.

I tried to unlock bootloader on it.
I followed the instruction.
First I go to the Dev mod then enable OEM unlock and USB debugging.
Second I typed:

adb devices

output:

List of devices attached
56090913288827  device

Then I typed:

adb reboot-bootloader

It became like this: enter image description here

Then I checked again:

fastboot devices

output:

56090913288827  fastboot

It seems all works out good! But then I entered:

sudo fastboot oem unlock

And then nothing. I mean absolutely nothing: it does not throw an error, not answers, not completes.
By the way, the phone does the same - absolutely nothing!
if I plug off the device it writes:

FAILED (Status read failed (No such device))
fastboot: error: Command failed

I tried it already ten more times but it doesn't want to work!

Does anyone know what the problem?
Did somebody have the experience in flash the fly(in particular nimbus 8)?
I'll de be waiting for an answer!
Thanks!

  • I don't know why but Mediatek devices (which your device is) do not have bootloader support via fastboot. If you are looking to install a custom recovery or a ROM, you need to use SP Flash Tool. Visit its site to know about is usage. – Firelord Jul 12 at 3:17
  • @Firelord This is the case! If I wanna install custom recovery I need to unlock bootloader! I already tried SP flash tool, but again, when I click download it do nothing. However, when I start it from the terminal it sees when i plug in or plug out the device. PS. Sorry for my grammar! – Mihail HRS Jul 12 at 6:56
  • try fastboot flashing unlock from windows with latest platform tools, linux platform tools have issues sometimes. SP Flash Tool can flash boot/recovery with locked bootloader. Do a readback first! Then try to flash stock boot/stock recovery first. if you can flash boot only, you can root with Magisk and write recovery with dd. if your device have MTK secure boot you need to find Secure Boot Download Agent – alecxs Jul 12 at 8:46
  • btw you have not installed Mediatek preloader VCOM drivers, you really need Windows for it. device must switched off for readback/flashing (flash with removed battery if possible) – alecxs Jul 12 at 8:56
0

The found out what the matter!
Fly nimbus 8 was delivered in two kinds: with MTK and with spreadtrum!
In my case it was with spreadtrum.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.