1

All of my background apps get killed when I turn off the screen. This is particularly annoying for my most-used messaging app, WhatsApp.

I've looked at the obvious "Battery Optimization" option: battery optimization

Based on advice found elsewhere, I've checked that the background process limit in developer options is the default (I've never changed this AFAIK): developer options

And yet, it gets killed in the same manner as battery optimization would. If I look at running background processes:

before poweroff

When I then press the power button, and power it back on after < 10s, the list is the same. But if I wait longer than that:

after poweroff

...whatsapp has disappeared.

This happens for all apps I install that have some sort of useful background feature - the Battery Optimization setting doesn't seem to do its job anymore.

What else can I try to diagnose this?

NB0: Android 7.0 on DOOGEE S60

NB1: This just started happening some time ago, i.e., it did work propertly when I got the phone.

NB2: I know how to use adb

NB3: I'm also fond of trying new apps and have ~400 apps installed. Ideally, I don't uninstall/disable all of them 1-by-1 to see which one is the culprit...

  • Install Addons Detector or any other similar app and filter to see which apps have permission KILL_BACKGROUND_PROCESSES granted. – Irfan Latif Jul 12 '19 at 4:32
  • @IrfanLatif hmm only 2 apps show up. 1 is MX Player (presumably because it can make itself the exclusive media player?), the other is Tasker (which I haven't used in ages). Both don't seem likely candidates...Uninstalling them, trying again. – Rody Oldenhuis Jul 12 '19 at 4:43
  • @IrfanLatif nope, no effect. Whatsapp is still killed. If it makes any difference, most of my widgets (clocks etc.) also stop updating after reboot + screen off...same thing I guess – Rody Oldenhuis Jul 12 '19 at 5:04
  • 1
    Use this method to track kill syscall. Requires root. – Irfan Latif Jul 12 '19 at 5:31
  • ...hmm. It would appear the DOOGEE S60 is not easily rooted. Not without significant effort and wiping the entire phone, that is. Any other suggestions? – Rody Oldenhuis Jul 12 '19 at 6:12
0

Go to "settings", "memory" and turn off "background auto clean memory".

| improve this answer | |
  • 2
    Hi, just for confirmation, is this for the device mentioned on the question, Doogee S60? Otherwise, you might note the device model since Android is highly customizable, and not every menu is there on every model/version. – Andrew T. Aug 5 at 8:39
  • Can confirm; that setting is not there on my model... – Rody Oldenhuis Aug 6 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.