2

For a client I build a private app which their employees can download on their tablet and use. To get the app, the employee opens Chrome on his tablet and navigates to an URL to start the .apk download.

This approach worked fine for the last few years, till a few weeks ago. Instead of installing the app, a folder is shown with the files of the .apk.

The only difference I noticed is the source that's stated in the 'Downloads' screen. On June 16th everything worked fine, the source says 'chrome-native://newtab'. As of July 1th, the source changed to the domain where the .apk was downloaded and this problem occurs:

The tablets are only used for this particular app. The company buys a tablet, navigates to the URL, downloads the .apk and installs it. It would like to keep it as simple as this.

I've searched everywhere, but still have no clue what causes this problem. Any ideas?

This problem occurs on Android 8.1.0, the upgrade form 8.0.0 to 8.1.0 may be the cause of the problem. But I still have no idea how to solve it.

0

I just had the same problem and was looking for an explanation.

If you tap on an .apk in that list a message (Toast) pops up saying it can't open the file, right?

A workaround I found is to open the file explorer app and manually navigate to the Downloads folder and tap on the .apk there. You'll be able to install the app without issues.
Or you can just use another browser, like Firefox.

My guess is that Google restricts Chrome from opening APKs. Funny enough you have to explicitly allow Chrome to download APKs but now you can't install them anymore… Still trying to wrap my head around this.

I'll edit this answer if I find out more.

  • I actually found the cause of the bug, just forgot to post it here. You have to set the right Content-Type header. It worked for me after setting that explicitly to application/vnd.android.package-archive. – Thijs Dec 4 '19 at 15:29
  • @Thijs Thank You, you've taken me in the right direction. A colleague set application/apk by mistake. However it only solved another problem (download not working), the problem with Chrome still persists. Do you know where else we need to set the Content-Type? We only added the MIME-Type in our IIS-Server. The APK is generated via the usual Android Studio function. It's the same with debug or signed release versions. One more thing i just noticed: Downloading it from a site works (virtual IIS directory, clicking on file), but opening a direct link to the apk seems to cause the problem. – Alex Dec 5 '19 at 8:34
  • I'm sorry, I don't know anything about that kind of setup. It worked for me in a Ubuntu/Apache 2 with PHP/Symfony 4 setup. – Thijs Dec 15 '19 at 10:39
  • Okay, thanks nonetheless. I really think it has something to do with the latest Chrome version or Android security. Because it works with every other browser or file explorer. Just not with the Chrome- or Downloads-App. I'll leep an eye on this. – Alex Dec 16 '19 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.