1

I am trying to root my phone,

  • I unlocked bootloader
  • I have uploaded Magisk-v16.6 to internal storage
  • I flashed by many twrp versions (fastboot flash recovery TWRP_3.2.3_TRT-LX1_by_kiruha_21.img/ twrp-3.2.3-4-land / boot-without-enciphering-data / twrp-3.3.1-0-CRO_U00 / TRT-TWRP-3.1.1-0818 /TWRP_3.2.2_TREBLE_TRT-LX1_by_kiruha_21 / twrp-3.3.1-0-whyred but every time when I start phone i twrp mode - touchscreen not working
  • I read https://forum.xda-developers.com/showpost.php?p=77597383&postcount=86

And I try to switch slot but when I run fastboot --set-active=a I get error: Device does not support slots. and when I run fastboot getvar current-slot I get

current-slot:
finished. total time: 0.002s

my fastboot version fastboot version 1:8.1.0+r23-5~18.04

0

The bootloader must load the DTBO image that is compatible with the recovery image. in your case Touch is not working because the TWRP version does not support it. There is not much you can do, the TWRP kernel must be compiled with touch support (or maybe binary hex-patched).

Look for dtbo.img or (edit: dtb is appended to kernel for y7)
use the adb shell commands TWRP comes with:
https://twrp.me/faq/openrecoveryscript.html

You can also try to boot TWRP from fastboot instead of flashing it, sometimes this will affect to touch screen work.

fastboot boot C:\adb\TWRP_3.2.2_TRT-LX1_by_kiruha_21.img

regarding switch slots, you can not switch if you don't have A/B device. don't mix up different recoveries.

please note the differences between /etc/recovery.fstab

only in TWRP_3.2.2_TRT-LX1_by_kiruha_21

/dev/block/bootdevice/by-name/userdata fs: f2fs  
/dev/block/bootdevice/by-name/  
vendor, product, version, log  

only in TWRP_3.2.2_TREBLE_TRT-LX1_by_kiruha_21

/dev/block/bootdevice/by-name/userdata fs: ext4  
/dev/block/bootdevice/by-name/  
fsc, lksecapp, sbl1, dip, dpo, limits, mcfg, mdtp, mota, oem, syscfg  

Please check if your phone has f2fs or ext4 file system, and check if vendor partition is present or not. Select the proper TWRP variant according to your partition layout.

you can check your partitions from adb shell or terminal emulator (one of these commands will work)

ls -d /dev/block/*/*/*/by-name/*
ls -d /dev/block/*/*/by-name/*
ls -d /dev/block/*/by-name/*

for file system type (one of these commands will work)

df -t ext4 /data
df -t f2fs /data
df -T /data
mount | grep "/data "
  • So, What version of twrp should I use? what twrp version is supported? – Jan Jul 20 at 8:51
  • the version does not really matter 3.2.2 or 3.2.3 should have minor differences – alecxs Jul 20 at 9:34
  • When I try adb shell twrp backup SDBOM I get error: Setting backup options: System Data Boot Compression is on Digest Generation is off Updating partition details... ...done * Total number of partitions to back up: 3 * Total size of all data: 2229MB * Available space: 9877MB [BACKUP STARTED] * Backup Folder: /data/media/0/TWRP/BACKUPS/J5Y7N17718005067/2019-07-12--22-53-24 Can not create '/data/media/0/TWRP' folder (Permission denied). Failed to make backup folder. Backup Failed Done processing script file – Jan Jul 20 at 12:59
  • /data is mounted? maybe related to encryption? share link to adb pull /tmp/recovery.log (pastebin.com) – alecxs Jul 20 at 13:19
  • you can save backup directly to PC adb backup -f data.twrp.ab --twrp compress data (the message "Now unlock your device and confirm the backup operation" can be ignored) – alecxs Jul 20 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.