0

Problem

I can not boot my Samsung Galaxy S5 into recovery mode after flashing TWRP.

Background

I am trying to install LineageOS on my Samsung Galaxy S5.

What I tried

I followed the install guide on the LineageOS wiki:
1. Installing heimdall, which I built from source to get v1.4.2, since the previous version could not complete the handshake with my phone (other people had the same error)
2. Checking if heimdall works by using heimdall print-pit, which it did
3. Flashing TWRP by using heimdall flash --RECOVERY twrp-x.x.x-x-klte.img --no-reboot. Keeping their disclaimer in mind I tried both the current version as well as two older ones. Heimdall outputs RECOVERY upload successful, and I disconnect the phone (after the device has been released).
4. Booting into recovery mode -> FAIL

Error

The device boots into download mode instead (and no, I did not accidentally switch the volume buttons). There is no error message.

Edit

I originally (and wrongfully) assumed the device to be Samsung Galaxy S5 LTE. It was, however, a Samsung Galaxy S5 Plus (at least this is how I explain the error).

0

Preface

I have found the solution to my particular problem now, but if someone else knows more about this feel free to improve my answer or post your own.

Solution

Annoyed with what I thought to be heimdall's fault, I turned to odin (not in a religious way).

This, however, gave me the same error. Close to desperation, I decided to check everything that I did again, and luckily so: Because the guide was emphasizing that the TWRP version has to be the correct one for the model, with not even a little deviation, I checked and found that what I thought to be be a Galaxy S5 was actually named Galaxy S5 LTE-A. However, the model read "SM-G901F", which belongs to the Galaxy S5 Plus. So after downloading the correct TWRP and LOS versions, everything went fine.

I am not sure if this was the only problem or if there is still a problem with heimdall, since the linked reddit thread suggests so.

Conclusion

All this may be very well due to me not being patient enough to get the correct model before I start. In this case, I still hope that my error can serve someone else in their search, seeing as I linked a lot of resources (and maybe other people make the same mistake as me).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.