3

I'm unable to switch to the street view when using the Google maps on my android phone. I updated the Google maps to the latest version and also the street view but unable still though. I turned off the satellite view and tried but the street view was still disable. I tried to finding informative videos regarding this and some forums but they didn't helped me. I would really appreciated if any one help me about this.

enter image description here

3
  • To make absolutely sure that street view is disabled because of your hardware, try to access street view on a street in a major city. There are some streets where street view hasn't been captured. These are usually back streets in small towns.
    – ctt
    Commented Apr 7, 2012 at 1:15
  • @ctt it is not supporting anywhere for me.
    – avirk
    Commented Apr 7, 2012 at 2:08
  • Working ok for me on same handset, might be down to the fact I have ICS on it...
    – t0mm13b
    Commented Oct 4, 2012 at 23:42

3 Answers 3

1

Most probably, Street View imagery is not available for your location (yet).

  • Cross check the web version with any PC for the same location that doesn't work on your phone
  • Check a well-supported Street View location such as Google HQ on your phone
0

It may take a couple of second for the Street View button to become enabled. Just leave the button for up to half a minute?

1
  • I leaved it at least for 1 minute but the button still disabled. :(
    – avirk
    Commented Apr 14, 2012 at 11:16
-2

Check the tables of supported countries on Wikipedia. Most likely, Street View is not yet available where you live.

1
  • 1
    That is not an answer by referring to a linky to wikipedia - suggest you re-edit your answer!
    – t0mm13b
    Commented Jan 15, 2013 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .