I can connect to the school's campus wifi, but when I try to get on Opera, it will not let me connect to any website. Apps that use the internet do not work. I get bars on the wifi. Usually, on the first connect from a new device, it will ask me to register my device. I am guessing that since I haven't registered with the new device, I cannot access the internet with any apps. The problem is that I usually get the page that asks me to register my new device when I try to connect to a website. Opera doesn't take me to that site, though. The wifi works on all other devices.

Edit: When I connect to the home wifi, it works.

  • 1
    Have you tried other browsers? This sounds like it might be something your campus IT would have to sort out. Apr 7, 2012 at 3:21
  • Yeah. Depending on the mode its in, and Opera will try to render sites using an intermediate server. This may not work out if your gateway is interfering with things in order to shoe you an authentication page. As Matt suggests, confirm that the stock browser also doesn't work. If it also gives problems and you're sure you're allowed to use the Wifi, work with your IT folks.
    – ctt
    Apr 7, 2012 at 3:45

4 Answers 4


You didn't specify whether you're using Opera Mini or Opera Mobile, Opera Mini uses compression proxy server to optimize the page for your device; and this almost invariably breaks in-browser wifi authentication page since the browser will try to connect to its proxy which it can't do because the gateway blocks access to the proxy until you authenticate. Opera Mobile by default do not use the compression proxy, but if you turn on the Turbo feature then it will use the proxy.

You still can use Opera Mini or Opera Mobile with Turbo if you authenticate using the regular Browser then switch to Opera. If you're using Opera Mobile, then switch off Turbo temporarily for the authentication page.


I've seen some lame WiFi gateways (especially at hotels) that only intercept correctly for top-level URLs like "http://www.somesite.com", but more specific URLs like "http://www.somesite.com/this/that/another" don't work because they get redirected to "" which doesn't work on the lame gateway.

So, try browsing to "www.google.com" or any other bare URL to trigger the login page.


I used to face the same problem for long time. But now I've got the solution. Very easy:

Go to Menu → Settings → Advanced → Protocol and choose HTTP only.

It works for me :)


Wi-fi is used for just wireless networking (not necessarily for internet sharing). So, if you get bars on wi-fi, it doesn't mean you've got internet access. Wi-fi can be used to share files or gaming, for example.

In your case, I suppose.. your school's campus wi-fi would be providing internet (the only purpose they advertise wi-fi campus). If you are unable to get to the internet, it means access control of wi-fi router is blocking you. Why? Ask wi-fi administrator. The probable reason: You haven't registered your device.

But, before asking wi-fi administrator, use Fing - Network Tools to check TCP connection with external host. If there's really a problem, contact wi-fi administrator. There's nothing more you can do.

Disclaimer: I answered after presuming that your apps can connect to internet over other wi-fi networks.

  • Reasons explaining downvote would be nice..
    – iOS
    Apr 7, 2012 at 19:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .