0

Okay so, I've tried multiple guides and seen multiple questions and problems similar to mine, but none of them helped me in any way.

I'm trying to flash the stock MIUI rom on a Pocophone F1 via adb sideloading on TWRP. However, I am presented with this error:

Starting ADB sideload feature...
Installing zip file '/sideload/package.zip'
Target: Xiaomi/beryllium/beryllium:9/PKQ1.180729.001/V10.3.5.0.PEJMIXM:user/release-keys
package_extract_file took 02s.
Patching system image unconditionally...
package_extract_file took 00s.
Updater process ended with signal: 7

And ADB says:

adb: failed to read package block: Input/output error

I've heard that this is due to:

  • being a stock recovery; however it is TWRP.
  • TWRP being out of date; however it is the latest version.
  • not wiping data before; however it is wiped and formatted.

I tried many versions of TWRP, and another recovery named OrangeFox, but none of them worked.

I can sideload other zip files through TWRP's ADB sideload feature, but I can't flash the rom. I also can't push the rom zip because it gives me this:

adb: error: connect failed: closed

I really need some help, as this phone is without an OS and therefore unusable at this point.

  • For the adv errors have you tried a different cable? The status 7 could be a few things such as: A missed typed updater-script though doubtful if it's a factory signed .zip, Corrupt zip, Wrong device version, Update adb. – Bo Lawson Jul 29 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.