0

I have a pocophone f1, I had installed a custom rom (lineage os) before and I remember having trouble getting twrp flashed before using my old ass laptop and it working just fine. Since then (I returned to the original stock room because camera issues) I have gotten a brand new laptop and I threw away my old one without thinking. Now I'm stuck with my brand new laptop and my high end custom built gaming PC. Both have USB 2.0 but I run into one of the following issues while trying to flash twrp via adb in command prompt (with admin privileges)

Keep in mind I have the latest USB driver issued by the xiaomi bootloader unlocker specifically for my phone and my phone always shows up when I type "fastboot devices"

After confirming that my phone is visible as a fastboot device I would proceed to type "fastboot flash recovery twrp.img" (I named the .IMG as twrp to save typing.)

90% of the time, the flashing cmd cursor would go down one line but stay blank like it was processing it, but I, as well as most the people reading this, know that the process should happen all within 2 seconds.

The other 10% of the time it would send back an error (I'm not at home right now so I can't give the exact errors but they vary, the one I most saw was like "transfer failed(unknown error)")

I was up until 2:30am last night trying everything and searching through every forum before finally giving in and making my own question. I hope I provided enough info, if not, let me know.

Thanks.

  • What are the other errors? In regards to the transfer error Trying different usb ports Trying different usb cables Update fastboot.exe Download another .img file and verify the md5. Double check the Bootloader is unlock – Bo Lawson Jul 30 at 10:28
  • Possible duplicate of android.stackexchange.com/questions/196871/… – Bo Lawson Jul 30 at 10:29
  • I had everything up to date and I had 3 different image files I tried. It definitely has to do with usb 3.0 drivers in Windows 10, I used the family computer that doesn't have any usb 3.0 at all and it worked with no hassle, no issues whatsoever. Had a custom room flashed within 20 minutes. If anyone has any solutions for people with only newer hardware available that would be great though. – KewlFox Jul 31 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.