0

I have a Nokia 3.1a (from Walmart), and it appears to be basically running stock android. Overall it seems to work well other than two annoyances. Can't go back to 3 buttons, stuck with gesture interface. And the annoyance that this thread is for. The mobile hotspot feature works as long as the screen is turned on.

As fun as it is setting the screen to time out after 30 minutes, I would love it, if it would stay on while the screen was off. I thought maybe the wifi chip was turning off. Google has hidden the "wifi on during sleep" setting, so using ADB I can confirm that wifi_sleep_policy is 2 (always on).

Also, under advanced settings, I have the timeout if no devices connected set to "never".

Any help would be appreciated!

0

And, It looks like I found the solution. It appears that when the screen is off, Wifi was scanning. Since Wifi can't be turned on when the mobile hotspot is turned on at the same time, it would stop transmitting the hotspot signal.

Solution: Settings>Network & Internet>Wifi>Wi-fi Preferences Turn off Automatic Connection to AT&T Wifi Hotspot. Settings>Network & Internet>Wifi>Scanning Settings Turn off Wi-Fi Scanning

  • Thanks for pointing me in the right direction. In my case, I had to also turn on "switch to mobile data automatically" under wi-fi preferences. – Joe V. Oct 18 '19 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.