0

I have Xiaomi Redmi note 3 that came in contact with a fire. I brought another one second hand and have transfered the mainboard from the melted phone into the new body. It seems to boot up but there is no output from the OS to the screen, the backlight comes on though. my pc recognises that there is a Redmi 3 plugged in but as i cant do anything on the phone screen i cant allow acces to files. I am 99% sure developer mode and usb debugging is enabled as i Installed the MIUI 8 OS on it myself via ADB. When i try to access it though command line ADB it says the device is unauthorized. I've tried restarting the server but that does not change anything. I know the screen is connected to the mainboard as it attempts to boot into fastboot and the fastboot logo is displayed on the screen but that is as far as it gets. Every article that I've read trying to fix this has required the user to change setting on the phone screen so they are useless to me. All i want it to copy my photos from the device onto my pc. Any ideas? TIA Bobby

migrated from superuser.com Jul 31 at 6:35

This question came from our site for computer enthusiasts and power users.

  • Probably It is asking for USB Debugging authorization, as your screen is not working, try to make it work first. – digiwizkid Jul 31 at 6:49
  • try fastboot boot C:\platform_tools\twrp-3.3.1-0-ido.img and then adb push C:\Users\Name\.android\adbkey.pub /tmp/ + adb shell + cat /tmp/adbkey.pub >> /data/misc/adb/adb_keys then reboot and use scrcpy xda-developers.com/scrcpy-control-android-on-pc If bootloader is locked, you must download firmware, mount system.img from linux, modify /system/build.prop with ro.adb.secure=0 and flash it with QPST via EDL mode – alecxs Jul 31 at 11:14
  • .. and maybe required to patch boot.img against dm-verity (which you must flash too) it is probably best to use another phone with Magisk Manager for this – alecxs Jul 31 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy