0

I have a Samsung Galaxy Grand Prime (SM-G530T1) and I would like to install a version of LineageOS onto it. This is the first time I have ever attempted something like this. I did manage to install TWRP v. 3.1.1 onto my recovery partition. It is able to "boot" into this, but when I go to install the LineageOS .zip file, TWRP says:

Updating partition details...
...done
Installing zip file '/external_sd/rr-oreo-j30_20180804_NIGHTLY-gprimelte.zip'
Checking for MD5 file...
Skipping MD5 check: no MD5 file found
Warning: No file_contexts
E3004: This package is for device: gprimelte,
gprimeltecan,gprimeltetmo,gprimeltetr,gprimeltevl; this device is .
Updater process ended with ERROR: 7
Error installing zip file '/external_sd/rr-oreo_j30_20180804_NIGHTLY-gprimelte.zip'
Updating partition details...
...done

I have tried Googling everything, and everything I see says to install a newer version of TWRP, but there is none released (that I can find). What should I do?

  • This basically occurs due to the developer of the custom ROM, and can happen either in TWRP or CWM. It is actually an assertion error, and can be bypassed by editing a certain file. You don't have to install/reinstall your custom recovery. At XDA developers, they have already solved the issue. Have a look here: forum.xda-developers.com/showthread.php?t=2522762 The solution is too large to copy and paste here. – Wrichik Basu Aug 12 at 7:44
0

You seem to have downloaded the wrong ROM, if you are 100% sure this is the correct rom it might be a bug in TWRP.

You could possibly try to reinstall TWRP like this:

  1. Download latest TWRP for your device (you already have)
  2. Copy it to phone via OTG or SD-card
  3. Select 'install' in your current TWRP
  4. Select 'image' option
  5. Choose the TWRP image file
  6. Select the type 'RECOVERY' when prompted, and flash it.
  7. Power off from recovery and boot it into recovery again and try to flash the ROM again.

Another thing you can try is wiping:

  1. Boot your device into recovery mode
  2. Select 'advanced wipe'
  3. Check 'cache', 'dalvik cache', and 'data'
  4. Wipe

Then after wiping try flashing the ROM again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.