0

I was updating my Galaxy grand prime by Odin and when Odin said that your update has been completed "passed",

I plugged off my android and after that it is not starting.

       I have tried to enter into download mode again and again. It is showing nothing on the screen not even charging sign. 

I also tried to enter into root mode but that does not work too.

I need a solution I have only this phone and can't afford a next so an immediate solution in necessary Please help me with it

  • Please reply to the question. – Sheikh Ahsan Aug 2 at 20:49
  • What version of Odin did you use? What detailed steps did you take to flash your device? Where did you download the update from (ink wiuld be nice) – Bo Lawson Aug 2 at 22:45
  • I used Odin 3.10 and download the Samsung kies from Samsung website and firmware from Sam mobile. – Sheikh Ahsan Aug 3 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.