4

I'm using an Allview Alldro P2 phone with Android 2.3.5. Fresh out of the box it worked like a charm. After a factory reset from Settings I couldn't install any apps from Google (Gmail, Youtube, etc).

Later edit : Gmail failed, Youtube failed, Google Maps worked... odd right?

I'm getting an error like "Problem parsing package" but if I download other apps, they work like a charm.

Any ideas? It's the first time I'm having this issue. Meanwhile I will be exploring this site for any clues.

Thank you.

  • Does Google Play work on it? Google Apps work on a special framework which your phone might be lacking? I know the Kindle Fire lacks the framework but I don't know if any other devices do. – Ben Brocka Apr 8 '12 at 15:07
  • maybe, but in the processes i see google services running, does factory resetting a phone cause such problems on other models? – cristi _b Apr 9 '12 at 17:19
1

This problem is taking place when you install Google apps APKs directly on phone.

The solution is installing Google apps image in Recovery mod.

You can always get the latest GApps for any android version such as Ice Cream Sandwich (Android 4.0.x), Honeycomb (Android 3.x), Gingerbread (Android 2.3.x), Froyo (Android 2.2.x) and Eclair (Android 2.1.x) from this address Latest GAPPSS

  • so it isn't an issue with the fact that i did a factory reset? also, why install from recovery mode? – cristi _b Apr 9 '12 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.