2

I was trying to boot from the sdcard, as I thought it was a boot order issue, I disabled the boot flag on the boot partition. Now my phone will not turn on, or enter bootloader. I have found various guides to booting from an sdcard, however they require flipping a switch on the board, which does not appear to be there. Any ideas on how to fix this situation. I would like to be able to get the phone to a working state again, without having to wipe it.

Edit: Having looked a bit more, the phone is detected by the kernel, as it displays in dmesg and is also listed by lsusb. This is on ArchLinux 5.2.13 I have tried qmicli but that appears to only work if the driver is cdc-mdm whereas it is using qcserial. when connected, it generates /dev/ttyUSB0 and /dev/bus/usb/002/* which is a character unbuffered device file.

  • please provide some introducing stuff – alecxs Aug 11 at 22:51
  • @alecxs What information would you like to know? – SolarFactories Aug 12 at 15:11
  • gsmarena.com/sony_xperia_tipo-4718.php is this the device you are trying to boot from? Where did you get the idea of booting from sdcard, and what is the reason/goal (what tutorial did you follow, link)? Which rom you trying to boot (download link)? – alecxs Aug 12 at 16:14
  • Nevermind, so you just asking about How to flash stock ROM without losing data? forum.xda-developers.com/xperia-j-e/general/… – alecxs Aug 12 at 16:26
  • I was not following a tutorial, I simply first thought I would try to lauch ArchLinuxArm on my phone, so I copied it from another sdcard to my phone's sdcard(ext_card). Tried to boot, but it booted as normal into android. I then set the boot flag on the arch partition. Still booted into android. Thought it would be due to boot order that it was not booting into arch, so I disabled the boot flag on the partition to boot into android. I then shut it down, whereupon it will not boot up again. Nothing happens when pressing and holding power or volume down; no LED when charging. – SolarFactories Aug 12 at 18:01
1

For booting from MicroSD card you need to heavily modify your ROM. The android boot partition is not like a PC BIOS. You need the bootloader to look at mmcblk1 instead of mmcblk0 which is hard-coded in various system files.
(for more information refer to Irfan Latif's documentation for QMobile Z8 on forum.xda-developers.com)

If your phone does not boot into fastboot mode it is hard bricked. Most devices have a emergency download mode from where you can repair your bootloader and flash ROM. For Qualcomm devices it is the EDL mode which can be reached via EDL mode cable/dongle or with a testpoint on the PCB circuit board.

For your old Xperia device you can use Androxyde Flashtool

For other Qualcomm devices use QPST

For MediaTek devices use SP Flash Tool

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.