1

Every once in a while my device get "stuck" - I send an SMS or Email, and they are received only after 10 minutes or later. The device can be "stuck" even when the phone is on, and running other apps.

I tried installing Push Notification Fixer apps, but they do not help.

When I send the test and the phone is not "stuck", I get a notification after about 10 seconds.

However, I do receive notifications for Google Voice and WhatsApp when phone is in "stuck" phase, so it does seem app specific issue. Also I have noticed that these 2 apps have permission receive data from Internet , which the Gmail app does not. Seems to be related to what type of push notification is used. see documentation.

Also I noticed the Google Play Store is unable to install/uninstall apps in this "stuck" phase.

  • 1
    The answer doesn't work lol. Btw, there's no way to fix delayed notifications on my phone. Some device manufactures have aggressive battery optimization changes that cause delays or even nothing may happen so no setting may work. The actual answer may be to get a different phone from different manufacturer sadly. And yes, Google introduced different ways, its possible one way or another may cause different reaction. – CmosBattery Aug 11 at 17:12
  • It does not make sense to block some functions when the phone is on and running other apps, which is already battery consuming. – david72 Aug 16 at 21:52
0

Try this by order:

  1. If you have any Power Safe App - turn it off

  2. If you have any Power Safe Mod - turn it off and test will it works

  3. Check for Wi-Fi sleep - go to Settinings >Connection > Wi-Fi > Advanced > ensure "Keep Wi-Fi on during sleep" option is set to Always

  4. Check for properly syncing data in the background - Settings > Data Usage > make sure "Restrict app background data" feature is turned off

  5. Try to delete Cache of app (SMS, email, gmail etc.)

  6. With this app which you try set it to maximum amout of time.

  • Tried all that. Except clear cache. I'll try and will report if fixed. thanks – david72 Aug 9 at 20:59
  • Ok still doesn't work. – david72 Aug 9 at 22:19
0

Here's a list of things you can try:

  • Make sure you haven't disabled the app by force quitting on it
  • Make sure power saving mode isn't on
  • Check Data usage to see if Background Data is enabled for the App
  • Turn off battery optimization from Battery Usage option for the App
  • Make sure that there isn't any third party overlayer that you've utilized which is utilizing the app sync permissions ( certain launchers/ addons may do so)
  • Clear cache for that particular App
  • Factory reset the Google app by selecting the Uninstall updates option
  • Install this app and set your heartbeat rate to 5 minutes. It's a quick fix for the issue. It's most probably a network driver issue which the company needs to patch up and in the meantime, you can use this app to ensure normal functionality
  • Tried all that. doesn't help. – david72 Aug 19 at 15:51
  • Then try installing the app that I've linked. It's a network framework issue and requires a company side fix. Also try to see if you can send them a ticket regarding your complain – Kaustubh J Aug 19 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.