0

I have a problem with apk install. I have a device without google play. The device is not preinstalled with google play. This is running android 7. I downloaded apk and copied to device. I allowed unknown sources function. I try install apk, I get follow error: the package appears to be is corrupt.

If I try install apk on Samsung Galaxy S7, it's everything very good.

I have tried to install 5 free applications to device without google play, but cannot install due to the above error.

Why? Thanks

  • 3
    I'd recommend you take a look at F-Droid. It's a place for free and open-source apps, and comes with its own app to browse the catalogs and install apps. For an intro including instructions, see my article series on F-Droid, starting with F-Droid: The privacy-friendly alternative to Google Play Store. // As for package corruption: maybe something breaks in your copy process; you didn't tell how you copied, so it's hard to say. – Izzy Aug 10 at 21:43
  • 1
    Why? Maybe you downloaded and tried to install packages incompatible with your CPU, your OS, etc. Try installing Yalp store. It will help you download apps from Google Play Store, – Reddy Lutonadio Aug 10 at 21:52
  • Since we're recommending stores as the fix lol, you can see if its on Amazon app store as you can just download their store app from amazon and install it then install the app from there. But the actual fix is that the apk isn't good for that device since the same apk works on another so you would need a different version of it. Its either this or the apk did not copy correctly. – CmosBattery Aug 11 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.