1

This question already has an answer here:

I am currently running the April 29th build of LineageOS for MicroG 16.0 on my OnePlus 5 (cheeseburger). I tried to update the device using the built in Updater, but the device just rebooted into TWRP and showed the TWRP logo screen for some time. After that, I got this error message:

Checking for MODEM build time-stamp 2019-07-18 14:56:39
Error: This package requires firmware version 9.0.7 or newer.
Please upgrade firmware and retry!
Updater process ended with ERROR: 7
Error installing zip file '@/cache/recovery/block.map'
Done processing script file

After searching for a solution, I decided it would be best to just backup my data and reinstall Lineage.

After looking through my options, I decided a Nandroid backup through TWRP was my best option. So, I tried to take one. This was the result:

createTarFork() process ended with ERROR: 255
Backup Failed. Cleaning Backup Folder.

If I adb pull my recovery.log, this is where I get my errors:

E:tar_open error opening '/data/media/0/TWRP/BACKUPS/[serial_number]/2019-08-10--23-11-06_lineage_cheeseburger-userdebug_9_PQ2A190405/data.ext4.win000'
Error creating backup.
I:Error creating tar '/data/media/0/TWRP/BACKUPS/[serial_number]/2019-08-10--23-11-06_lineage_cheeseburger-userdebug_9_PQ2A190405/data.ext4.win000' for thread 0
Error creating backup.
I:ERROR tarList for thread ID 0
Error creating backup.
I:InfoManager saving '/data/media/0/TWRP/BACKUPS/[serial_number]/2019-08-10--23-11-06_lineage_cheeseburger-userdebug_9_PQ2A190405/data.info'
createTarFork() process ended with ERROR: 255

I read up about this type of error and found out that it means that those files have been corrupted and should be deleted. The strange thing is that the day before yesterday when I deleted the files in the /data/media/0/TWRP/BACKUPS/[serial_number]/ and then tried to perform the backup again, it regenerated files in the same directory, causing the same error. I also find it strange that the files that are causing the backup to fail seem to be backup files as well, although I've never performed a successful Nandroid backup on my device.

So, what can I do to fix this error and finally be able to backup and update my device?

marked as duplicate by Firelord Aug 13 at 9:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.