1

I have a rooted Mi A1, and upgraded to the latest LineageOS daily build (Pie). Most things work OK, however I can no longer change the MAC address of my device (which worked on stock). I'm trying to work out if this is something I can hack/fix.

I have downloaded a couple of programs to change the MAC address, and have also tried in an ADB shell. What I noticed is that when the MAC address changes the connection appears to go down, and then when it comes back up its reset to the original MAC address.

The driver appears to be wcnss_wlan and the chipset on the phone is, I think, MSM8960 (but could be wrong here).

When I manually try and bring the interface up at the command prompt using ip link set dev wlan up, it does not work (I can bring it down OK, and can change the MAC OK using ip link set dev wlan0 address ma:ac:ad:dr:es:ss ), and when I use the toggle on the phone the interface gets reset to its default MAC.

Can anyone advise a way to fix this, or point me (even vaguely) in a productive direction - ie where can I find where the MAC address is coded, how to I manually trigger a DHCP update? How do I look at whats happening with WPA_SUPPLICANT ?

  • Why did you installed LineageOS in a Android One device?, I guess it's for fun. Anyways, my experience with custom roms and daily builds is that nothing should be expected to work, so don't waste your time trying to solve something broken. – Jose Antonio Navarro Marco Aug 13 at 12:25
  • @JoseAntonioNavarroMarco I installed LineageOS because Android was not getting updates under stock as I have rooted it and as such there are significant vulnerabilities on a device which holds keys to other systems (and also the phone is 2 years old). I really did not want to update, but I'm glad I did. LineageOS/Pie is more polished. Importantly I disagree with your philosophy about not solving problems in daily builds - its part and parcel of open source. – davidgo Aug 13 at 19:40
  • I'm an android developer myself and I can assure you daily builds are far from being released, far from being stable, and far from a smooth experience. Anyways, if you still want to solve this problem, ask in lineageOS forums, contact the developers directly, maybe they can help you, they are the only ones that know how does something done yesterday works. – Jose Antonio Navarro Marco Aug 14 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.