0

My question is similar to [Undo "Disable autofill for [app]" one), but the solution doesn't work for me, so please bear with me.

I'm using Keepass2Android for autofill. It works great in most apps. It also worked in Firefox until one day I pressed Enable autofill for [website URL]. Now it doesn't work for this website. There's no autofill popup, so I can't undo this like I could in other apps. I've also done this in Firefox Preview and it stopped working altogether for all sites in that browser.

What I've tried:

  • Solution from this question - I don't have the 3 dots button
  • Reinstall Keepass2Android - no change
  • Reinstall Firefox - no change
  • Clear Firefox cache and data - no change

I'm using OnePlus 6T with latest OxygenOS (Android P-based).

1
  • The issue went away either due to Keepass2Android update last month or upgrade to Android 10. I won't try to enable autofill now because I'd rather have it working and I don't want to take any chances.
    – gronostaj
    Nov 12, 2019 at 13:23

1 Answer 1

1

External autofill apps change a certain boolean in the Firefox for Android configuration variables, this "setting" can nly set back to the old setting by completely uninstalling and reinstalling Firefox or better by changing it in: about:config

  • goto about:config
  • search for: dom.forms.autocomplete.formautofill
  • set it back to true
  • refresh your login window and... fixed!
2
  • As I wrote in the question, reinstalling Firefox didn't fix it. I can't verify if about:config method works because the issue went away on its own.
    – gronostaj
    Nov 12, 2019 at 13:21
  • 1
    looks very possible that the reinstalling Firefox method does not work as by default Google (Play Services) saves and syncs app settings for when you reinstall them. But I had the same problem and for me the about:config method worked.
    – Kleajmp
    Nov 12, 2019 at 13:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .