1

TL;DR - How to uninstall the Google Play store?


A friend of mine deleted my Google Account as a prank (don't know how it is a prank). When I came home, I just logged in and tried to install some apps, but it wasn't downloading and stuck on Download Pending. Here is a list of troubleshooting I did:

  1. Force stopped and disabled. Cleared data and cache. Uninstalled updates. Restarted the APK but still didn't work. Yes, I also gave it time to update.

  2. I deleted all my other accounts and just kept my Google Account. Did the same as 1), didn't work.

  3. OK. I remembered that there are modded Play Stores available online. So I downloaded the Lucky Patcher Google Play Store (modded) ver. 14. something and it didn't work. Also, did 1) again after I installed it.

  4. When I uninstall the update for the modded app, it requires authorization, meaning I would have to sign in again. No problem, but there is no option to log out, meaning the arrow drop-down doesn't appear. Also, I signed out from Settings and relogged in from Play Store, but still, when I open it, it asks for authorization again.

  5. I tried to install the Gapps again. In the XDA forum, it was stated that you just need to install the package again and it will replace the existing Gapps. I did it. I downloaded the nano package. But it asks for Authorization. Still no drop-down.

I am back again with the Lucky Patcher app. It will let me browse APK and use Play Services, but it won't let me install APKs.

How to uninstall Play Store and reinstall it?

1
  • As you installed GApps on your own you are using a custom ROM. May be just just ran into the Google certification for custom ROMS which is now required. Old installations continue to work, but it is required for new installations. Deleting and re-adding the Google account may be considered by Google as new installation: lineageos.org/Google-Play-Certification
    – Robert
    Oct 16, 2019 at 11:02

1 Answer 1

0

I had a similar issue after trying to install a custom ROM onto an old tablet. In my case, the solution was to change to a different build of GApps.

I had tried to install the Slim6 ROM (Android 6.0.1 Marshmallow) onto a Samsung Galaxy Tab 2 GT-P5110), with Open GApps Pico (also tried Nano). This appeared to work: I could add my Google Account and browse apps in the Google Play Store, but anything I tried to install or update just hung on "Pending..." None of the normal advice about clearing caches worked. I fixed the problem by installing the Delta version of GApps base, after which everything seemed to work fine. I didn't even run into the Certification issue mentioned by @Robert - maybe my setup was too old!

If you run into the Pending Downloads problem after installing a custom ROM, my advice is to research the threads for your ROM in the XDA Forums, and look for a known-good version of GApps that works with that ROM. Hope this helps someone else in the future!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .