0

I tried restoring a TWRP backup of my Pixel 3 and it ended up putting my phone into a bootloop. I downloaded the latest factory image and reflashed (not knowing the latest version bootloops when Magisk is flashed). I downloaded the last version to support Magisk but a) held off on rooting for a little bit b) accidentally flashed the newer one a second time. Fast forward to now: I spent the time (quite a long time) to reinstall and configure all my apps and then realized my mistake when I looked at my terminal when I went to root.

I tried adb and Google backups, but neither are backing up any non-Google app. Is there anyway to make a backup of my app data without root? Could I take a twrp backup of just my user data and restore it once I flash the version that supports rooting? Or will the changes that caused encrypted data to not be supported by twrp not be compatible? If the user data can't be restored by twrp, is there any way to unpack the twrp backup and manually transfer the data with adb push? Or could adb pull work?

0

adb backup should work at least on some apps. Test it for example with a simple tea timer or stopwatch app those apps should not disallow backup. If this does not work the backup function on your device may be defect (encountered this once on a Lenovo tablet).

But if it works for simple apps that the it is just that the other apps disallow backup (android:allowBackup=false set in AndroidManifest.xml). Note that this settings affects disables adb backup as well as Google Cloud backup.

If the app disallows backup then there is other way to backup the data except using root permissions.

However if you have root and TWRP installed you may be able to perform a user data backup. However AFAIK this only works if TWRP is able to decrypt the user data. If you only see the encrypted files or the encrypted partition I doubt that restoring those files will later work on the same device (it will never work on a different device).

Note that a (decrypted) user data backup independently how it was created can not be directly restored via ´adb push`. For doing so adb would have to run with root permissions which is usually no longer possible (unless you have a manipulated adb version on the device).

What you can do with root permissions is backup and restore app user data. For example manually by using tar in an adb shell with root permissions.

  • @Robet Thanks for the info. The question still stands for the second half, though. – anon Aug 27 at 8:42
  • @anon See my updated answer – Robert Aug 27 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.