5

I have a Huawei P20 Lite with Android 9, EMUI 9.1.0 and WhatsApp 2.19.253, which is the latest version.

As I wrote in the title, I can't receive WhatsApp messages, after many hours of researching I didn't find any solution for my problem. This is the first time I face whit this problem, because I managed and configured variues P20 Lite but none of them gave me that headache.

The things which I did:

  • Turn on every single option for WhatsApp's notifications;
  • Uninstall the application and install it again;
  • Remove the app from the battery optimization process;
  • Clear the cache;
  • Enabled automatic start, secondary start and running in background, following this steps Settings -> Battery -> app launch -> 3 vertical dots -> manage manually;
  • No limit for internet traffic and allow background data, following Settings -> networks and wireless -> data usage -> select WhatsApp -> enabled the varius option.

Any idea or solution for this problem?

EDIT

When I send a message from my phone to this P20 Lite, on the message appears only 1 tick, such as the P20 is disconnected from wifi/mobile data, but the wifi is enabled and connected, the same behaviour with mobile data.

6
  • 1
    Have you disabled background data for Google Play Services? This service is used for notifying Whatsapp of new messages. See this question and it's answers for details: android.stackexchange.com/questions/216714 – Robert Sep 12 '19 at 18:53
  • @Robert No, the only things which I did, are wrote in the answer – Leonardo Bassi Sep 13 '19 at 8:37
  • Does your phone never receives messages when the screen is off or is there just a long delay. Let someone send you a message and leave the phone alone for may be 30 minutes. – Robert Sep 13 '19 at 9:29
  • @Robert Yes, the phone receives messages when the screen is lock, but after 5-10 minutes WhatsApp stop doing is background work such as the system kill the process. When I open it everything works well, instant messages with screen on and off – Leonardo Bassi Sep 13 '19 at 9:42
  • The OP in this thread also had the same issue as you and it was solved by going to «Setting--> battery optemization --> select "all apps" on the little arrow and go to Whatsapp and select " Not allowed"». There is another solution also on that thread. I know you wrote about battery optimization but try once more, you never know. – Reddy Lutonadio Sep 13 '19 at 16:08
0

I just had this issue here with P10 - WhatsApp would not receive until opened or at least running in the background. Now it receives even if closed. I solved it by:

Settings > Search for setting > Ignore battery optimisation

If by 'Allowed' apps you don't see Whatsapp, click on the corner triangle for 'All apps', search for Whatsapp and 'Allow'

0

I had similar issues with late or no notifications showing up, eg for Snapchat, Messenger.

It is called PowerGenie and it kills all apps that are not on its whitelist. You cannot add custom apps on their pre-defined whitelist. This means there is no other way to fix proper app functionality on Huawei than uninstalling PowerGenie.

https://dontkillmyapp.com/huawei

Basically you can remove PowerGenie without root using ADB:

adb shell pm uninstall -k --user 0 com.huawei.powergenie
adb shell pm uninstall -k --user 0 com.huawei.android.hwaps

After I removed those packages I receive notifications 100% of the time for all my apps, just how it should be (and with no impact to battery life that I can see).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.