1

I'm migrating from a Samsung Galaxy S4 Mini to a Redmi Note 3 whos bootloader I unlocked and then updated to Android Pie. Whenever I try to use the account that is already used by the Samsung device I get an error because (allegedly) the installed Google Play Services or the Android version are less than the supported ones (please see screenshot below). The error displayed is "update required ... This device needs newer software". Before this screen is shown I shortly see a screen with "Parental permission" on it, which is the screen that I would expect in order to connect this (second) device with the Family Link app for parents.

This error should not be shown because Android Pie (=9.0) is way more current than the demanded Android 5 and my play services are version 19.x

These are my attempts so far:

  • tried different custom Android Pie ROMs (Pixel Experience, liquid, aex, ...). All of them show the same effect.
  • flashed pico, micro and stock opengapps, makes no different
  • checked date and time to make sure they are current (they are)
  • went to Settings / Apps and deleted cache and more (didn't help)
  • checked for working Google Play Servics with a diagnostic program (they are recognized and have a real up to date version)
  • updated Play Services with an APK from apkmirror (same effect)
  • instead of linking the account in the setup agent I skipped this part and linked the account (or tried to) via Settings/Accounts

None of them helped. Others have the same problem but no solution either: https://forum.xda-developers.com/redmi-note-3/help/google-family-link-kenzo-t3850734

enter image description here

  • Is your android version is 5 or 5.1? – M. Rostami Sep 15 at 11:11
  • It is Android 9 (Pie) – Marged Sep 15 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.