0

I can't get any of my apps to work. I've tried

clearing the data & restarting - works for 10 min then back to square one

force stopping - won't let me

uninstalling updates - it tells me it's unsuccessful

Disabling google play, reenabling, then restarting - still nothing

What else can I do? This is so frustrating.

  • try factory reset – ahuja007 Sep 17 '19 at 12:50
0

I had the same problem today (just after updating my phone) and eventually found a way to uninstall Google Play Services updates, thanks to the thread in Google Play Help Forum:

I was able to fix the issue today, by uninstalling the Google Play Services updates. Could only do that after making sure 'Find My Phone' was no longer a device administrator. Steps I followed:

  1. Go to Settings -> Lock screen and security -> Other security settings -> Device Administrators
  2. Uncheck 'Find My Device'
  3. Go to Settings -> Apps -> Google Play Services
  4. Tap the vertical ellipsis (3 vertical dots) at the top right -> Uninstall updates
  5. Go to Settings -> Apps -> Google Play
  6. Tap the vertical ellipsis (3 vertical dots) at the top right -> Uninstall updates
  7. Restart phone. At this point the message "Google Play services keeps stopping" was gone.
  8. Open one of the Google apps (in my case Google Maps)
  9. It complains that "Google Play services" is outdated, click the popup to update it again. Problem solved. Really happy to have my phone back ;)

It worked for me (no more error messages, and now I can use again apps such as Google Play Store, Google Maps, etc)

|improve this answer|||||
0

Thank you! I, too, had tried all the other fixes, and I couldn't get this one to work either for a while, until I found the right place to disable "Find my Phone." For me, it was here: Settings --> Biometrics and Security --> Other Security Settings --> Device Admin Apps

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.