Just yesterday I thought of having a new ROM installed on my phone and it is not the first time I'm doing it. Though I made a mistake of not taking a backup of the system before flashing the custom ROM.

These are the steps that I followed:

  1. Moving to bootloader and rebooting to TWRP recovery
  2. Wiping the cache, system, data and dalvik cache
  3. Moving to install option and installing the CustomROM1.zip from the Internal Storage
  4. But the screen is stuck at boot animation
  5. Using my laptop I tried to do the following:

5.1. fastboot erase system and fastboot erase recovery

5.2. Flashed TWRP recovery again using fastboot flash recover twrp.img

  1. Moved the CustomROM2.zip file in the Internal Storage and tried to flash it using install option but resulted in boot animation loop

I even tried to ADB sideload and flash the zip but resulted in the same error. Currently I'm on Moto G Play (Harpia) and the ROMs that I used are

CustomROM1 = Resurrection Remix v. 5.8.3

CustomROM2 = Eelo v. 0.7

Any sort of help to get out of this would be totally appreciable. And thank in advance.

2 Answers 2


After much try and waiting I couldn't get any satisfactory result out of it. So ultimately I had to flash the stock firmware. The name of the firmware could be deduced from the command fastboot getvar all


This is the link anyone who's facing the same issues can refer to.


Have you confirmed the integrity of the file you're flashing? I have had some that wouldn't flash and after trying every variable, I re-downloaded the file and it flashed no problem. Also consider: after successfully flashing the ROM, boot back into recovery or to the bootloader before booting the system.

  • Yes, I checked the integrity of the custom ROMs twice for both of them. Since both of them were showing same sort of results I couldn't stop myself from thinking that the problem lies within the system and not the software being flashed.
    – Tintin
    Oct 4, 2019 at 15:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .