0

A few days ago, I tried installing a MIUI 11 ROM for my K20, but forgot to flash a zip that disables force encryption so now I have a brick on my hands. I've tried fastboot format/erase userdata, mkfs.f2fs, format data on TWRP, and Repair FS on TWRP, but have been met with barely any success. I'm at a total loss after trying to find a solution to this issue for about 3 days now. What's worse is that TWRP takes about an hour to boot. Does anyone here know what else I can try? Is there a way to quickly force wipe /userdata and get rid of that encryption?

Edit for list of things I've already tried besides the above: -Flashing universal disable script from zackptg5 -Disabling dm-verity and forceencrypt in TWRP -Using mkfs.ext4 /dev/block/[userdata partition] (hangs on writing super blocks) -Using mkfs.f2fs /dev/block/[userdata partition] (hangs after the first few lines) -Re-flashing stock firmware via MiFlash -dd trick provided in this post: Removing encryption from recovery -gdisk (says no partitions when trying to list or delete)

  • If gdisk says no partition then your partition table is certainly corrupted. May be a dying flash memory. – Irfan Latif Oct 3 at 7:38
  • It's unlikely but I won't count that possibility out. The phone is brand new and only a month old. I think it's tied to me failing to disable dm_verity and forceencrypt before booting. – BrickedGuy01 Oct 3 at 13:05
  • dm-verity and forceencrypt (dm-crypt or fscrypt) are both kernel features. When you are in recovery you are booting a different kernel and a different OS. mkfs in recovery must not fail weather dm-verity/dm-crypt were enforced in main OS or not. Just do a complete wipe of userdata using dd if=/dev/zero and then create filesystem. I can't think of any reason for this to fail if the partition exists. – Irfan Latif Oct 3 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.