I have installed TWRP through Odin, then I booted it. I only seen it, I haven´t done anything, just rebooted to the system again, and it got stuck on trying to boot the system.

It's Samsung J7 Prime with Oreo, Odin 3.13 and TWRP-3.2.3-For-Galaxy-J7-Prime.tar

So, what the hell? Why is it not booting? Any idea?


Can you boot into TWRP? If you can I would try these steps:

  • Boot into TWRP

  • Once TWRP is booted you first need to wipe your /data partition or go into Wipe > Advanced Wipe and make sure Data is ticked then swipe to wipe.
    If this is your first boot into TWRP: swipe Wipe > Format Data from left to right and follow the instructions displayed onscreen.

  • Once it's finished go back to the home screen and swipe Reboot > Recovery from left to right. TWRP should be able to mount your data partition.

  • Now flash the no-verity-opt-encrypt zip you downloaded from this link, put it on an SD Card and flash it by going to Install > %zip location% This zip prevents your phone from bootlooping since Android Oreo uses dm-verity to prevent modification to the system.

  • You are (hopefully) now able to reboot to your OS without bootlooping.

    Hope this helps.

  • 1
    Thanks Joe. I was in the process that led me to wiping, but I didn't want to wipe, so I tried to do anything else. As soon as I ran out of hope I can preserve the data, I wiped it. And it was back to normal. – Ketersis Oct 5 '19 at 16:33
  • 1
    wipe is just necessary for fixing problems with decryption - if your twrp does mount your data partition successfully, you can continue with installing no-verity.zip without wiping data – alecxs Oct 6 '19 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.