1

I use Realme 3 pro device with SD710 running android 9.0 with ColorOs UI, and i'm trying to root my device with Magisk module. First i followed the instructions at link to unlock bootloader,then followed this link to install TWRP recovery for flashing Magisk to root my device, but after that the device cannot boot-up and i have this message on screen :enter image description here i tried these solutions to overpass this message :

  • Disable verity-check using ADB with command ./fastboot - disabled-verity - vbmeta flash-verification-enabled vbmeta.img but i get error fastboot: usage: unknown command - .
  • Disable verity-check by flashing a zip from this link.
  • Try to patch stock boot.img by using Magisk manger followed the instructions link.

noticed: Secure boot status still yes in fastboot mode, and the device only boot-up iff after flashing the stock boot.img and stock recovert.img but with no root. So i think the problem caused by secure boot, how to solve it? and if there is another one what could it be?

Thanks for advance.

0

Install the stock recovery first through fastboot. Then install twrp recovery again through fastboot. Then install the zip file of the stock rom. It worked for me. Get the stock recovery and stock rom from https://forum.xda-developers.com/realme-3-pro/how-to/guide-to-stock-rom-stock-recovery-t3940604

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.