0

I am trying to unlock bootloader on Desire 320, but failing on retrieving the OEM number:

$ fastboot oem get_identifier_token
...
FAILED (remote: unknown command)
finished. total time: 0.004s

I've also tried flashing recovery with TWRP directly using

$ fastboot flash recovery <recovery.img>

But that failed with security deny, error code 0x2017. I've rooted the phone using KingoRoot but that did not change anything.

I've even tried an automated application HTC Bootloader Unlocker, but this app failed on the same step as I did. Also, after investigating its logs, this app tried to read various variables using fastboot and could not read any of them.

I've also tried to update ROM directly from stock recovery using both SD card and ADB sideload, but both installations were canceled (but sideload on itself works).

The phone specs and prerequisities:

  • android 4.4.2, core version 3.4.67
  • Developer mode unlocked, USB debugging enabled (was able to send adb/fastboot commands)
  • Unverified applications can be installed (was able to install KingoRoot)
  • Cannot enable OEM Unlocking option as many guides suggest (this option does not exist in my phone)
  • Cannot use RUU (my phone does not have a carrier)

The question:

  • Am I screwed or is possible to unlock this device (and how?)
  • If you have rooted your device have you tried to install TWRP using the "Official TWRP App"? – Robert Oct 9 '19 at 17:52
  • Tried it just now and I bricked the phone – doomista Oct 10 '19 at 18:37
0

There seems to be an issue with USB3.0 and Fastboot. Fastboot commands won't work on a phone which is conencted via a USB3.0 port. In order to investigate further and look for the solutions, I need you to crosscheck this first. Try running other fastboot commands such as:

fastboot reboot 

and see if it works.

  • Yep, this command worked, but as I stated in another comment, I've tried Official TWRP App and now phone's completely bricked. – doomista Oct 12 '19 at 14:03
  • Does your phone enter a boot loop or is it not able to boot at all? Also, are you able to enter the fastboot mode? – Danish Shakeel Oct 13 '19 at 15:11
  • No fastboot, no recovery, no boot loop. It doesn't even vibrate. It is completely bricked. – doomista Oct 16 '19 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.