0

After the Sept Update (now shows "Software update to T827VVRU3CSH4), my Verizon Galaxy Tab S3 stopped "supporting" the SD card that I've been using for the past year or so. It now does 1 of 2 things for all SD cards:

  1. Displays a message "Unsupported SD card". "This device doesn't support this SD card. Tap to setup in a supported format". I've tried formatting the same, previously working SD card a few times now, but no luck. I've also tried 2 other SD cards, but they too cause the same, repetitive formatting prompt.
  2. Doesn't recognized at all

Has anyone else experienced this recently? I'm wondering if it might be a bug in the recent update, or something specific to my tablet + SD cards.

  • Have you tried a different SD-card? Or at least remove and re-insert the sd-card to make sure that the cause is not hardware aging of the connectors. – Robert Oct 7 '19 at 17:01
  • I tried rewording the description to better clarify, but yes, I've tried several SD cards, and they all cause the same, endless prompts for formatting. – swv Oct 7 '19 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.