0

For over a year my phone had no issue connecting to my computer via usb cable. I could transfer files back and forth via adb no problem. It stopped being recognized about a month or two ago, So I've been using adb over network.

It doesn't even show up in lsusb.

  • I thought maybe it was the cable, so I tried a different cable.
  • I thought it was the usb port on the computer, so I tried other usb devices. Phone charges when plugged into computer though.
  • I thought it might be the connections of the cable to the phone and computer, So I cleaned them with alcohol.
  • I thought maybe the connections on the mainboard of the phone, So I pulled the phone apart and cleaned the connections with alcohol.
  • I thought maybe adb needed to be updated/reinstalled, so I did that.

So here's my predicament. I was updating LineageOS and there was a problem with the firmware so I reset my phone without thinking. That deleted all my files on the sdcard as well as the system. So I'm only able to use twrp (recovery, no OS). But the phone should be able to mount still since twrp allows MTP.

Any ideas what I can do to get the phone to be recognized by the computer.

Stats:

phone: OnePlus 3T - up to date TWRP only, formerly LineageOS

computer: Ubuntu 18.04, up to date adb and fastboot

  • Replace the USB port, it's a common issue in the 3 & 3T... in time it will stop charging as well. It isn't a software/firmware issue, and we can't give you a solution via Android or Linux, the port is physically failing. – acejavelin Oct 12 '19 at 16:25
  • 1
    thanks @acejavelin I bought a new port and will report back in a couple days. I asked this same question on xda and two people said the same thing as you – winchendonsprings Oct 14 '19 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.