I got an XA2 and did all the updates, which gave me Android 9. I have a few other Android devices but all on versions 6 to 8.

I routinely use FTP servers on Android devices to get files onto them. And it always worked - but on this one, does not work. I start WiFi FTP and it says it has started but the PC can't connect to it.

Upon some forum advice, to see if the issue is with the FTP protocol, I installed Asus File Manager, which accepts HTTP connections for remote file transfer. Still no connection.

Moreover even a ping does not get through!

However, the phone successfully uses the Internet over the WiFi connection. It is also listed in the router's list of connected devices, though it is shown as having no host name, while other Android devices have host names.

So how can I get Android 9 (on Sony Xperia XA2) to accept incoming connections on WiFi/make FTP servers work? Or is this just perma-disabled in Android 9 and/or in Sony's mod?

  • I'm using SSH + FTP server on Pie for more than a year I think, even accessible on internet. Did you try connecting over hotspot? Android doesn't show hostname, that's expected: android.stackexchange.com/a/217171/218526 – Irfan Latif Oct 15 '19 at 22:36
  • Hotspot connection worked! WiFi FTP Server sees no files for whatever reason, but ASUS File Manager works. It gives the wrong address in the UI but when I get the right address from WiFi FTP UI, I can use ASUS File manager. I can find an FTP server that will work now, probably. But I do wonder what is happening about a regular Wi-Fi connection. – Mikhail Ramendik Oct 15 '19 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.