1

I have Samsung Galaxy J9 running on Android 9 Pie. I bought Grapher Pro from the Play Store and installed it. When I tried to run it, a message was shown:

This apk was built for an older version of Android.

Because of this, I refunded it.

Is there any way to run such apps? The free version doesn't show the issue though.

1
+50

You may try to change the target Android version of the app using APK Editor and change the API version. But it most likely won't work for paid apps. Instead, you can try to run the app in a virtual machine in which an older version of Android is installed. See VMOS Virtual Root Android on Android-Double System.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.