I have a rooted (and unlocked) Huawei Ideos X3 (U8510). I have complete backups of the stock ROM using ClockWordMod installed to the sdcard.

Then I started playing with different ROMs on the internet. At some point I also flashed the device with another GENERIC Stock ROM for this device. At this point, the generic Stock ROM permanently changed my static boot logo and the boot animation. Originally it was a static Huawei logo with Vodafone animation (Red Vodafone logo). That was replaced by the static Huawei logo AND Huawei generic boot animation. This is the problem as:

  1. I need to replace with the original static boot logo and boot animation in the event of a warranty claim.
  2. I need the assurance that recovering to the stock ROM backup will restore everything to the way it was except the bootlogo and boot animation.

Now if I revert to the stock ROM from the backup (via ClockWorkMod recovery), everything from the backup is restored EXCEPT for the static boot logo and the boot animation sequence.

Things I have tried:

  1. From the installed terminal, as su: I tried copying the recovery.img from the backup to the root of the sdcard. Then as su, I executed the following command:

    flash_image recovery /sdcard/recovery.img

The above command worked. I rebooted into recovery. Then I rebooted again but still am seeing the generic static Huawei boot logo and boot animation.

I can see the following files from my stock rom backup:

recovery.img   ---> This is the file I copied to the root of the sdcard.

I have also tried asking in other forums to get the copy of the boot animation from the stock ROM with no success.


Do I have the original boot logo and boot animation from stock rom backup (above file list)? If so, is there a way to recover it? If not: is there a known source to get the original boot animation?

Thanks in advance for your help.

1 Answer 1


OK: After some more reading, it looks like ClockWorkMod did not back up the /cust partition ie: /proc/mtdblock7 in which the vodafone logo and boot animation was stored. When I flashed my device with a generic Stock ROM that overwrote the /cust partition permanently. When I flashed my recovery.img, it only restored the recovery partition (which was the CWM Recovery image after rooting).

The only way I can now get back the stock voda animation is backup the partition (via dd maybe) from another device to an sd card and flash back to my device partition from the sd card.

Moral of the story: Backup all partitions (via ROMDump or dd) and not just rely on ClockWorkMod backup which ignores these partitions.

I arrived at this conclusion by checking my logs from the saved data partition (after rooting) when I saw this file in: /data/load_oemlogo.txt which references /cust/vha/au/logo/oemlogo.mbn

load_oemlogo begin
command_line_is: console=ttyDCC0 androidboot.hardware=huawei
androidboot.localproppath=vha/au androidboot.network=umts 
androidboot.swtype=normal androidboot.mode=boot mem.size=256M
ret_str = vha/au androidboot.network=umts androidboot.swtype=normal   
androidboot.mode=boot mem.size=256M

custom len = 6 
custom : vha/au 
logo path /cust/vha/au/logo/oemlogo.mbn!
stat file error!
load_oemlogo end

Update: Yes I can confirm that the /cust and /userdata2 partition are not backed up by CWM backup and restore.

I quote from translated version (german) from here:

Completely importantly! Make always only times with CWM a Backup.


zip load down and in the CWM over “Install zip from sd-card” would drive out. 

The two partitions are cust and userdata2 secured, which does not make the standard Backup of CWM. 

Afterwards cust_backup.tar and userdata2_backup.tar should be to the SDCard the two files.

Now would drive the file out install_new_partition_layout.zip. 
A new boat and Recovery image are installed, because in both the new Kernel COMMAND LINE must be contained. 

Auserdem becomes still the volume demon (/system/bin/vold) and its configuration file /system/etc/vold.fstab it then a few volumes to mounten gives less replaced there.

Now one bootet by means of advanced->Reboot Recovery into the again installed CWM.

There one re-establishes over backup and restore - > advanced restore - > Restore DATA the data partition from the previous Backup. 

EDIT: More info and updates.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .