lately and seemingly out of nowhere my phone has stopped updating Gmail when on data, even when I manually try to synch. Google Maps and Play also won't work, although everything else does, like Reddit or Chrome. When on WiFi, no problems whatsoever.

I am using a Xiaomi Pocophone F1, running MIUI Global 10.3.8 / Android 9 PKQ1.180729.001.

This has been going on for weeks. So far I have tried erasing the affected apps' cache to no avail, and removed my Google Account from my device. When I tried this last step and tried to sign back in, I got a message saying "There was a problem communicating with Google servers.", so it didn't help either.

Any help would be hugely appreciated as I feel like this is way beyond my capabilities!

  • If you try using your phone as a mobile hotspot and let others connect through your hotspot, can they use Google services? Also, do others using the same SIM provider as you facing the same issue, or is it only you? Since you didn't do anything, and it happened out of nowhere, and you can still browse others, one of my suspicions is that your SIM provider blocks Google services for unknown reasons. Have you googled if it happens with others?
    – Andrew T.
    Commented Oct 27, 2019 at 8:37
  • I haven't tried it with other people's phones, but when I hotspot my computer I can access Gmail so I don't think it's that? It's only me facing this problem with this provider, and none of the solutions I could find online so far were able to solve anything. Only thing I can think of is that this phone was bought in Singapore and I'm using it in Australia, where the device supports only 3 of the 4 bands the provider uses. But then again I didn't have any issue the first 4 months here...
    – user286537
    Commented Oct 28, 2019 at 0:27
  • Please run this on your console and revert: adb shell dumpsys telephony.registry Commented Oct 31, 2019 at 5:07

1 Answer 1


I followed several online troubleshooting guides for similar problems but nothing worked. In the end, I had to resort to a factory reset, and that sure fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .