1. This is not a proximity sensor issue. The proximity sensor works as expected during normal calls and speakerphone calls.
  2. This is not a screen timeout issue. The screen timeout is set to 10 minutes. It always turns off within <45 seconds.

as expected during normal calls and speakerphone calls.

This is infuriating. I don't understand why the screen should turn off after any amount of time other than the screen timeout setting when on a speakerphone call. Usually I'm navigating automated menus and it goes out a second or two before I'm ready to input the option. A simple tap doesn't wake it either I have to pick up the phone and press the power button.

This is with a Samsung Galaxy S10e.

How can I make the phone respect my screen timeout settings when on speakerphone calls?


2 Answers 2


My LG 3 Auto updated to a 3 seconds screen timeout. I was unable to change it in any Settings menu. The solution I found is to download a Screen on app. I use the Keep Screen On Free app that works perfectly and allows you to change the timeout too.

  • I have added a link to your app I found in the Play Store. If the link is incorrect, do let me know or edit it out.
    – Firelord
    May 19, 2020 at 9:47

The reason why the screen turn off when making calls is to prevent keypad press and high battery consumption during the call so that you're not suddenly got cut halfway in the call.

As for how to keep the screen turn on during the call, there are a few ways you can do it. I suggest Screen On Call app. If the app doesn't work, try to use a headset on call.

  • 1
    We know what they think it should turn off. But simple analysis makes it clear there is no genuine reason. Keypad press is not relevant since you're on speakerphone not with the phone against your ear and you've intentionally turned on the keyboard so you can press it. Battery is irrelevant as it's mostly black pixels and again you've intentionally kept it on. If you want to save battery life it's one button. It sounds like you're confused with the screen turning off when not on speakerphone which would be correct behaviour. As made clear, the phone is overriding set screen timeout settings. May 19, 2020 at 13:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .