4

I've got a problem while trying to install/upgrade any app on my android phone, after tapping on install/upgrade it just get stuck with the message waiting for download.

Nothing works for me, I already tried these solutions and their combinations:

  • Restarting the phone
  • Clearing google play store cache/data - force stopping it
  • Clearing google play service data
  • Clearing download manager cache/data - force stopping it
  • Uninstalling and reinstalling Play Store updates (also I have tried it without reinstalling)
  • Removing & re-adding my Google account from device
  • I've got enough free storage [+3G]
  • I'm on a WiFi with good connectivity.
  • There is no new version of Android available to upgrade for my phone
  • I also tried installing apps from browser, didn't work!
  • I tried installing apps using a VPN too, Wrap from CloudFlare is the only thing on my phone and it didn't work either.

I'm on Android 8.1 Motorola products, if it makes any difference.

  • install apk files – alecxs Nov 8 '19 at 15:36
  • Thanks but that would be the obvious thing to do... I rather solving the problem. – FooBar Nov 8 '19 at 17:53
  • assuming you have enough free space for downloading and installing apps, try another wifi maybe it's just a network connection problem not related to your phone. if you're not sure about free space wipe cache from recovery and clear cache for every app from app settings – alecxs Nov 8 '19 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.