2

I need help..

I have a redmi 4a device, with android 7, I formatted a 64 gb ADATA SD card as internal storage, worked great for long, until after a restart the SD card is corrupted with precious data on it..

It says tap to format, but it doesn't format, I tried on my laptop and windows cd and Easeus partition manager, but none worked..

I lost hope to fix the SD card, but the phone isn't accepting to show photos or store any data, even with new card identical to the old is mounted.. it says unmount usb storage.. When I try to see a photo status on whatsapp, says can't download because no internal storage is available, please unmount it as a disk drive, and try again.. Also I can't see any picture sent to me in chat..

I tried to format the new card as internal, but same problem..

Any help?

1

In general fixing an sd-card with corrupt data should be done on raw disk not on partition level, overwriting potential corrupt partition data.

Assuming that the sd-card is physically fully working the best way to reset it is by overwriting the first blocks with zeros.

Unfortunately I don't know a good erase tool that works on Windows and that works on RAW disk level. On Linux this can be easily done using dd writing to the block device of the sdcard (e.g. sdb, sdc or something like this).

For Windows the Hex editor HxD may be an alternative if you know what you are doing. It allows to open the full disk in read-write mode and then you can overwrite the first few kilobytes. Just make sure you are writing to the correct disk (and not overwriting e.g. your main HDD/SSD).

Once you have managed to reset the sd-card eject it and then re-insert it. Then format it on the PC and apply then test it using the tool H2Testw. It fills the sd-card with dummy data and then verifies if the all the written data can be read.

  • thanks buddy.. and very sorry for replying so late, – Saruman N. Nov 17 at 4:12
  • I don't have a linux, but I inserted an identical sd card into my phone, but didn't work.. Tried to format it as internal, but still says turn off USB storage and try again.. – Saruman N. Nov 17 at 4:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.